Hi all,
I've been thinking again about the support for linear operators (MATH-581). If RealLinearOperator is ever included into CM, then I think AbstractRealMatrix should extend RealLinearOperator. Then, the interfaces should be as consistent as possible. That's why I renamed some methods
getDomainDimension ---> getColumnDimension
getCodomainDimension ---> getRowDimension
even if "rows" and "columns" are not really meaningful for a matrix-free linear operator. I will probably be more understandable this way.
Also, the signature of the default constructor has been changed
was: RealLinearOperator(domainDimension, codomainDimension)
which would translate into: RealLinearOperator(columnDimension, rowDimension) ===> INCONSISTENT WITH AbstractRealMatrix
is now: AbstractRealMatrix(rowDimension, columnDimension)

I've attached a new file (#04) to JIRA MATH-581. Unfortunately, I don't know how to remove the previous files, so this ticket is getting messy, I'm sorry about that.

Hope this new proposition will be agreeable to all.
Sebastien


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org
For additional commands, e-mail: dev-h...@commons.apache.org

Reply via email to