Hi,

While fixing MATH-406, I had to introduce two quantities: wjacobian and
wresiduals corresponding to the weighted Jacobian of the residuals and
the weighted residuals respectively.  I had to do this because the
field names are somehow misleading.  For instance, the field 'jacobian'
has two different meanings:
 - in DifferentiableMultivariateVectorialFunction, the Jacobian is the
   matrix of the gradients of the function.
 - in AbstractLeastSquaresOptimizer, the Jacobian is the matrix of the
   gradients of the weighted residuals.
To reduce the confusion for the potential contributors, it might be
wise to avoid to use the same name for the two quantities.  The field
jacobian from AbstractLeastSquaresOptimizer might be renamed
weightedResidualsJacobian to remind what its content is.

The same is potentially true for the residuals.  I needed a weighted version
so I added wresiduals.  However, from what I see in the rest of the code,
there is no accessor to the residuals per se.  So, one could drop residuals
and only keep weightedResiduals.

Does anybody think of a situation where the Jabonian of the model (i.e.
without the weight and the sign change) would be useful and should therefore
be kept separately?  Same question about the genuine residuals (i.e.
unweighted).  Otherwise, I would drop the two unweighted fields.

Regards,
 Dim.
----------------------------------------------------------------------------
Dimitri Pourbaix                         *
Institut d'Astronomie et d'Astrophysique *      Don't worry, be happy
CP 226, office 2.N4.211, building NO     *         and CARPE DIEM.
Universite Libre de Bruxelles            *
Boulevard du Triomphe                    *      Tel : +32-2-650.35.71
 B-1050 Bruxelles                        *      Fax : +32-2-650.42.26
http://sb9.astro.ulb.ac.be/~pourbaix     * mailto:pourb...@astro.ulb.ac.be

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org
For additional commands, e-mail: dev-h...@commons.apache.org

Reply via email to