[ https://issues.apache.org/jira/browse/TRANSACTION-9?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12516170 ]
Oliver Zeigermann commented on TRANSACTION-9: --------------------------------------------- Folks! (I) The main problem with the tx file system is that other programs might access the files managed by the "tx file system". That's why commits reps. rollbacks might fail. That would not be any different with any other transactional resources. Look what happens what Oracle does when you format the paritiion it works on ;) Bottom line is: Sometimes you just can not guarantee all transactional properties. Thus: Both strategies are more or less ok. (II) Concerning 2PC: I agree to what Jörg says and will add a prepareTransaction() to the "MangeableResourceManager" (strange name?!). However, most implementations will not be able to *really* support 2PC. Anyway, it is good to at least support it in case a resource manager really supports it. (III) Real locking on the file level would be a nice idea. Let's see if we can get that implemented. (IV) Concerning casts: Every time you access a resource (ResourceManager#getResource, Resource#getChildren(), Resource#getParent) you will have to cast when you have two interfaces for file and directory. Not even java.io.File does that. Why should we? > [transaction] Add full file management capabilities to the FileResourceManager > ------------------------------------------------------------------------------ > > Key: TRANSACTION-9 > URL: https://issues.apache.org/jira/browse/TRANSACTION-9 > Project: Commons Transaction > Issue Type: Improvement > Environment: Operating System: All > Platform: All > Reporter: Peter Fassev > Assignee: Oliver Zeigermann > Priority: Minor > Fix For: 2.0 > > Attachments: filemanager.zip > > > Hi, > As stated in the doc the FileResourceManager is: > "A resource manager for streamable objects stored in a file system" > I agree, that this is a resource manager, but it could be easily extended, to > support a full file management system. It will be very helpful to have > additional methods like renameResource(), getResourceSize(), > getResourceTime(), > setResourceTime() etc. This are common file operations, which should be > managed > by the FileResourceManager. > Further it will be very helpful to have (real) support for resource > collections > (folders). It will be necessary to distinguish between single resources > (files) > and collections (folders). > Together, this features will enable a transactional access to any file based > resources - for instance a document repository. > Are there plans for such extensions and if not, will they actually fit in the > goals of the transaction library? > If not, please open the underlying structure, like the inner class > TransactionContext, in order to add extensions the file management. For > instance, it will be good to have a separate factory method, which creates > the > context. > If you are interested in this proposal, I am ready to contribute to this > project. I consider myself as an experienced java developer and I will be > glad > to help you. > Best regards > Peter Fassev -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online. --------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]