-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/12110/#review22494
-----------------------------------------------------------


1. Move txn code to method removeFromDB.
2. Rename removeFromDB to more meaningful name and possibly move it to vlanDAO
3. Don't suppress exceptions, use these to surface errors.
4. Don't use finally from txn.commit.
5. Check if you need to return values from your methods at several places or 
possibly eliminate these returns.
6. For checking conditions and the possibly acting on those donot use that many 
booleans.

- Abhinandan Prateek


On June 27, 2013, 10:57 a.m., bharat kumar wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/12110/
> -----------------------------------------------------------
> 
> (Updated June 27, 2013, 10:57 a.m.)
> 
> 
> Review request for cloudstack and Abhinandan Prateek.
> 
> 
> Bugs: Cloudstack-3106
> 
> 
> Repository: cloudstack-git
> 
> 
> Description
> -------
> 
> Cloudstack-3106 Delete all the ips except for the ip alias.
> https://issues.apache.org/jira/browse/CLOUDSTACK-3106
> 
> 
> Diffs
> -----
> 
>   engine/schema/src/com/cloud/dc/VlanVO.java a2f7a9c 
>   server/src/com/cloud/configuration/ConfigurationManagerImpl.java 041f29a 
> 
> Diff: https://reviews.apache.org/r/12110/diff/
> 
> 
> Testing
> -------
> 
> Tested on master.
> 
> 
> Thanks,
> 
> bharat kumar
> 
>

Reply via email to