As regards the prefix versus attribute debate, I would
prefer to use a prefix.

(1)    <script language="javax:javascript">
          print("Hello world\n");
       </script>

(2)    <script language="javascript" manager="javax">
        print("Hello world\n");
      </script>

(1) is I think nicer.

The reason I don't like (1) is that it makes it look like an XML
namespace prefix, while it's not. This is main point of my objection.
It's kinda similar to my push to not use the ${NAME} syntax in
<macrodef>, but the different @{NAME} one. I really would like us to
avoid *overloading* the meaning of notations in Ant build files, which
are XML as of now, and thus should strive to respect as much as
possible XML's tenets.

Here are alternative notations, for example:
[EMAIL PROTECTED] ==> too email like
javax/javascript
javascript[javax]
javax+javascript
etc...

Actually, I kinda like the javax+javascript one. As I've written a few
times, as the _talker_ rather than the _doer_, I wouldn't -1 the
javax:javascript, if others feel it's the best one, but I think it's a
bit confusing and misleading in an XML file. --DD

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to