Hi, For a long time we have had types nsAutoString and nsAutoCString which are strings with 64 chars of inline storage. They are good for holding short strings, most often on the stack, because they avoid the need to heap allocate a char buffer.
I recently landed patches (bug 1386103) that introduce nsAutoStringN and nsAutoCStringN. These are like the existing types but their length is a template parameter. So if you want an nsString with 128 chars of inline storage, you'd use nsAutoStringN<128>. If you want an nsCString with enough inline storage to store an nsID you'd use nsAutoCStringN<NSID_LENGTH>. nsAutoString and nsAutoCString have been redefined as typedefs for nsAutoStringN<64> and nsAutoCStringN<64>, respectively. I have updated the MDN docs appropriately: https://developer.mozilla.org/en-US/docs/Mozilla/Tech/XPCOM/ Guide/Internal_strings Nick p.s. The "Auto" in these names is confusing. "Auto" in Mozilla code usually refers to an RAII wrapper type such as AutoPtr or AutoLock. nsInlineString and nsInlineCString would be better names for these types... but that's a change for another day. _______________________________________________ dev-platform mailing list dev-platform@lists.mozilla.org https://lists.mozilla.org/listinfo/dev-platform