Hey. Just some cosmetic point:
Should this really be called git-delta? It seems it's not just for git, and upstream names it just "delta" (which is however already used by some other package). What about diff-delta? Or perhaps color-delta? Or ideally asking upstream to pick a better name!? ;-) Cheers, Chris.