Hi Todd, On Fri, Apr 08, 2016 at 07:11:28AM -0400, Todd Treangen wrote: > > >We intend to package parsnp[1] and when downloading the archive from > >Github[2] I realised that it contains some binaries we need to replace > >by Debian packaged binaries built from the according sources to enable a > >distribution in main Debian. > > fantastic! one question I have; I'm working on a new release that > addresses a few important issues and will add a couple of new > features. I'm not sure on the timing of this, but hope to get it out > soon. If this is after it is integrated into Debian, how difficult is > it to replace/update to the latest version?
Once a package made it into Debian its in most cases a matter of 15-30min work to get the update prepared. So in our specific case it makes sense to package the current version (with the initial packaging work on my side + waiting for the initial acceptance on the Debian mirror) and upgrade once you have released the new version. > >However, when calling bin/harvest_linux and the result from packaging > >the output is different: > > harvesttools is the correct one to use; harvest_linux can we replaced > with a build of harvesttools source OK. > >Moreover I wonder where I can find the source for bin/Profile > > agreed, the name is quite generic; no problem to rename if necessary. It would be great if you would come up with a renaing suggestion to make sure we do not invent some name you don't like. > http://www.maths.otago.ac.nz/~dbryant/software/PhiPack.tar Is there any *versioned* tarball and some kind of web page that could be considered a "homepage" which we usually add to our metadata? > >Finally you are shipping a copy of libMUSCLE[5] which has three changes > >applied > > yes, that is correct > > >I think upstream of libMUSCLE would be happy to profit from these > >changes as well. > > ok, alternatively, I was intending to set the max_thread_count to the > maximum available threads on a system. I was unable to successfully > implement this change (via omp_get_thread_num()), so instead, set > this to a large value (64). thoughts/recommendations? This mail goes in CC to our mailing list. May be there are some ideas. > >I plan to apply these to the official Debian package > >since it seems sensible to me and link parsnp against this library > >dynamically. > > agreed, this makes sense OK. > >What do you think? > > all of this sounds great, thanks again for your time/effort getting > parsnp packaged into Debian. You are welcome - thanks for providing parsnp as free software Andreas. -- http://fam-tille.de

