On Thu, 2011-05-12 at 00:45 +0000, Thorsten Glaser wrote: > Debian Ports Archive Maintainer dixit: > > >Accepted: linux-2.6_2.6.38-5_m68k.changes > > Since I can’t get the build logs to show up in the PTS (or > at http://buildd.debian-ports.org/status/package.php?p=linux-2.6 > rather) I’ve put them up on my place, in case someone wants > to have a look at it and/or fix one of the at least 241 > warnings popping up ☺ > > https://eurynome.mirbsd.org/~tg/pub/linux-2.6_2.6.38-5_m68k.build.gz > > I’ve booted into the Atari kernel just fine so far.
Looking through the warnings: > debian/bin/patch.apply:81: DeprecationWarning: functions overriding > warnings.showwarning() must support the 'line' argument Fixed on trunk. > Warning: No version.Debian file, assuming Debian Linux 2.6.38 Not sure why we bother with this warning, but it's harmless. > .config:555:warning: symbol value 'm' invalid for LEDS_CLASS > .config:917:warning: symbol value 'm' invalid for MFD_WM8994 Fixed on trunk. > warning: (NETFILTER_XT_MATCH_REALM) selects NET_CLS_ROUTE which has unmet > direct dependencies (NET && NET_SCHED) The dependencies for NETFILTER_XT_MATCH_REALM should be fixed. But why is NET_SCHED disabled on m68k, anyway? > <stdin>:1522:2: warning: #warning syscall recvmmsg not implemented Missing feature on m68k. > arch/m68k/mm/cache.c: In function 'flush_icache_range': > arch/m68k/mm/cache.c:58: warning: 'mmusr' may be used uninitialized in this > function > arch/m68k/mm/cache.c:51: note: 'mmusr' was declared here The warning is incorrect and could be suppressed by adding mmusr to the list of clobbered variables for the asm statement. > security/keys/keyctl.c:1403:2: warning: #warning TIF_NOTIFY_RESUME not > implemented Missing feature on m68k. > drivers/char/tpm/tpm_tis.c:96: warning: 'is_itpm' defined but not used The definition of this function should be conditional on CONFIG_PNP. Anyway, I don't think the TPM drivers could be used on most non-x86 architectures. We should just disable them. > drivers/ide/ide-io.c: In function 'ide_lock_host': > drivers/ide/ide-io.c:415: warning: passing argument 2 of > '__constant_test_and_set_bit' discards qualifiers from pointer target type > arch/m68k/include/asm/bitops_mm.h:30: note: expected 'long unsigned int *' > but argument is of type 'volatile long unsigned int *' > drivers/ide/ide-io.c:415: warning: passing argument 2 of > '__generic_test_and_set_bit' discards qualifiers from pointer target type > arch/m68k/include/asm/bitops_mm.h:42: note: expected 'long unsigned int *' > but argument is of type 'volatile long unsigned int *' The m68k definition of __constant_test_and_set_bit() is wrong; it should include the volatile qualifier. > drivers/net/wireless/p54/main.c: In function 'p54_register_common': > drivers/net/wireless/p54/main.c:614: warning: unused variable 'priv' > drivers/net/wireless/p54/main.c: In function 'p54_unregister_common': > drivers/net/wireless/p54/main.c:656: warning: unused variable 'priv' Fixed in 2.6.39. > CC [M] drivers/net/zorro8390.o > drivers/net/lib8390.c:256: warning: '__ei_tx_timeout' defined but not used > drivers/net/lib8390.c:302: warning: '__ei_start_xmit' defined but not used > drivers/net/lib8390.c:526: warning: '__ei_poll' defined but not used > drivers/net/lib8390.c:879: warning: '__ei_get_stats' defined but not used > drivers/net/lib8390.c:981: warning: '__ei_set_multicast_list' defined but not > used > drivers/net/lib8390.c:1016: warning: '____alloc_ei_netdev' defined but not > used It looks like zorro8390.c should be using these functions instead of the corresponding functions without the double-underscore prefixes. At the moment it's using some functions built from the #included lib8390.c using the special definition of EI_SHIFT (from zorro8390.c), and some functions exported from the 8390 module, which are built with the default definition of EI_SHIFT (from 8390.h). > CC [M] drivers/net/hydra.o > drivers/net/lib8390.c:256: warning: '__ei_tx_timeout' defined but not used > drivers/net/lib8390.c:302: warning: '__ei_start_xmit' defined but not used > drivers/net/lib8390.c:526: warning: '__ei_poll' defined but not used > drivers/net/lib8390.c:879: warning: '__ei_get_stats' defined but not used > drivers/net/lib8390.c:981: warning: '__ei_set_multicast_list' defined but not > used > drivers/net/lib8390.c:1016: warning: '____alloc_ei_netdev' defined but not > used Similar issue in hydra.c. > CC [M] drivers/parport/parport_pc.o > In file included from drivers/parport/parport_pc.c:67: > arch/m68k/include/asm/parport.h:14:1: warning: "insl" redefined > In file included from arch/m68k/include/asm/io.h:4, > from include/linux/scatterlist.h:8, > from include/linux/dma-mapping.h:7, > from drivers/parport/parport_pc.c:54: > arch/m68k/include/asm/io_mm.h:234:1: warning: this is the location of the > previous definition [...] At a guess, the definitions in include/asm/parport.h are redundant and should be deleted. > drivers/video/mb862xx/mb862xxfb.c:326: warning: 'mb862xxfb_init_fbinfo' > defined but not used > drivers/video/mb862xx/mb862xxfb.c:464: warning: 'dev_attr_dispregs' defined > but not used Bug in the Kconfig. This driver should not be built on non-PCI machines. > CC [M] net/ipv4/netfilter/ipt_LOG.o > In file included from net/ipv4/netfilter/ipt_LOG.c:27: > include/net/netfilter/xt_log.h: In function 'sb_close': > include/net/netfilter/xt_log.h:50: warning: value computed is not used Looks harmless and certainly not m68k-specific. > WARNING: modpost: Found 1 section mismatch(es). > To see full details build your kernel with: > 'make CONFIG_DEBUG_SECTION_MISMATCH=y' Don't know; do what it says if you care. > drivers/hwmon/pc87427.c: In function 'pc87427_readall_fan': > drivers/hwmon/pc87427.c:182: warning: unused variable 'iobase' [...] The dummy definitions of inb() and outb() etc. in include/asm/io_mm.h don't use their parameters. This driver obviously isn't going to work, even though its dependencies are apparently met. I don't understand what the dummy definitions achieve. > CC [M] drivers/net/wireless/rtlwifi/rtl8192ce/dm.o > In file included from drivers/net/wireless/rtlwifi/rtl8192ce/dm.c:32: > drivers/net/wireless/rtlwifi/rtl8192ce/reg.h:353:1: warning: "GPIO_IN" > redefined > In file included from arch/m68k/include/asm/io_mm.h:30, > from arch/m68k/include/asm/io.h:4, > from include/linux/scatterlist.h:8, > from include/linux/dma-mapping.h:7, > from include/linux/dmaengine.h:26, > from include/linux/skbuff.h:30, > from include/linux/if_ether.h:126, > from include/linux/etherdevice.h:27, > from drivers/net/wireless/rtlwifi/rtl8192ce/../wifi.h:36, > from drivers/net/wireless/rtlwifi/rtl8192ce/hw.c:30: > arch/m68k/include/asm/atarihw.h:403:1: warning: this is the location of the > previous definition [...] This seems like a bug in both the driver and the architecture. The name is too generic and the 'GPIO' prefix really belongs to gpiolib. > CC drivers/scsi/atari_scsi.o > In file included from drivers/scsi/atari_scsi.c:1089: > drivers/scsi/atari_NCR5380.c: In function 'NCR5380_queue_command_lck': > drivers/scsi/atari_NCR5380.c:917: warning: unused variable 'oldto' Looks like it is left over from commit 8ce7955aa52c37db1425ea4bd4edcfa67e253454 and can be deleted. > drivers/scsi/atari_scsi.c: At top level: > drivers/scsi/NCR5380.h:303: warning: 'NCR5380_exit' declared 'static' but > never defined The Atari driver probably should be calling this function at some point. > drivers/video/aty/atyfb_base.c:2270: warning: 'aty_bl_exit' defined but not > used Use is dependent on CONFIG_PCI, but definition is not. Definition should be fixed. > drivers/tty/serial/8250.c: In function 'serial8250_shutdown': > drivers/tty/serial/8250.c:2236: warning: statement with no effect Seems like the same issue as before with dummy definitions in io_mm.h. > arch/m68k/mac/misc.c: In function 'mac_hwclk': > arch/m68k/mac/misc.c:309: warning: 'result' may be used uninitialized in this > function > arch/m68k/mac/misc.c:309: note: 'result' was declared here It is used before initialisation on the first iteration through line 326. I think it would be reasonable to initialise result.idata to 0 before entering the loop. > drivers/scsi/mac_scsi.c:220:5: warning: "NDEBUG_ABORT" is not defined > drivers/scsi/mac_scsi.c:271:5: warning: "NDEBUG_ABORT" is not defined Should be #ifdef NDEBUG, not #if NDEBUG. > arch/m68k/mvme147/config.c:152:2: warning: #warning check me! > arch/m68k/mvme16x/config.c:261:2: warning: #warning check me! These warnings have been present since the start of git history. Please put these platforms out of their misery. Ben. -- Ben Hutchings Once a job is fouled up, anything done to improve it makes it worse.
signature.asc
Description: This is a digitally signed message part