Hi, Am Sonntag, den 02.02.2014, 19:31 +0100 schrieb gregor herrmann: > On Sun, 02 Feb 2014 18:05:45 +0000, Jonathan Dowland wrote: > > > A > > > maintained version is available as a separate package, > > > libfile-rename-perl. > > This is a frustrating package name for an end user binary. Reminds > > me of the difficulty I have remembering which package the LWP-tools > > "GET" and "HEAD" live in. What's wrong with "rename"? > > It's the package for the CPAN File::Rename distribution, and > therefore named accordingly to > https://www.debian.org/doc/packaging-manuals/perl-policy/ch-module_packages.html#s-package_names > in Debian. > > But yes, adding a "Provides: rename" wold probably make sense. > > (Cf. also > http://pkg-perl.alioth.debian.org/policy.html#package_naming_policy )
sounds more like it should be named "rename" and have a provides "libfile-rename-perl" – assuming there will be more users looking for the package of rename than of File::Rename (which I do assume, being a regular user of the one but not of the other). Greetings, Joachim -- Joachim "nomeata" Breitner Debian Developer nome...@debian.org | ICQ# 74513189 | GPG-Keyid: 4743206C JID: nome...@joachim-breitner.de | http://people.debian.org/~nomeata
signature.asc
Description: This is a digitally signed message part