On Mon, Feb 13, 2012 at 11:48:36PM +0100, Romain Francoise wrote:
> Colin Watson <[email protected]> writes:
> > It would be nice to just use dh_installdeb's support for generating
> > dpkg-maintscript-helper commands, which was introduced in debhelper
> > 8.1.0.  This would remove duplicate code from your maintainer scripts.
> > Here's a patch: [...]
> 
> Nice, thanks Colin. debhelper adds a prerm script to the package with a
> no-op call to dpkg-maintscript-helper, but that's not really a concern.

Right.

> I merged your patch in Git for the next upload.

Thanks!

> I guess that also takes care of half of #648867 which I'm going to retitle
> and tag accordingly.

Yes, the postinst part of the patch in that bug is wrong for Ubuntu as
well as for Debian.  We shouldn't be using conditional paths when we can
use dependency relations to guarantee a single path.

Cheers,

-- 
Colin Watson                                       [[email protected]]



-- 
To UNSUBSCRIBE, email to [email protected]
with a subject of "unsubscribe". Trouble? Contact [email protected]

Reply via email to