Hi André, On Thu, 2010-09-16 at 09:48 +0200, Andre Espaze wrote: > On Tue, Sep 14, 2010 at 06:20:34PM -0400, Adam C Powell IV wrote: > > On Tue, 2010-09-14 at 11:05 +0200, Andre Espaze wrote: > > > > > > > Package: salome-dev > > > > > > > Version: 5.1.3-11 > > > > > > > Severity: wishlist > > > > > > > > > > > > > > It will be nice to include adm_local directory for each salome > > > > > > > "base" modules > > > > > > > in the salome-dev package. This will greatly simplify the > > > > > > > developpement and > > > > > > > packaging of new plugins since the configuration step almost > > > > > > > refers to > > > > > > > MODULE/adm_local. > > > > > > > Otherwise we ave to include some MODULE_SRC in the src package > > > > > > > for the plugins > > > > > > > (see what I have done for salome-code-aster on svn debian science) > > > > > > > > > > > > This is a good idea. Right now the package puts the .m4 files all > > > > > > together in one big salome.m4 in /usr/share/aclocal (because > > > > > > "check_KERNEL.m4" and "check_GUI.m4" are far too generic names). > > > > > > But > > > > > > something like /usr/share/salome/[module]/adm_local or > > > > > > just /usr/share/salome/adm_local could include more than just the > > > > > > .m4 > > > > > > files. > > > > > > > > > > > > /usr/share/salome/adm_local is the easiest place to put these. Will > > > > > > that work for you? > > > > > > > > > > I would rather try to stick as much as possible to the "original" > > > > > installation. So my feelings are that adm_local from MODULE_SRC should > > > > > be included in /usr/share/salome/MODULE_SRC. > > > > > > > > It's pretty easy either way. André, as someone closer to upstream, what > > > > do you think makes more sense? Right now, all of the adm_local files > > > > install into /usr/adm_local, which violates the FHS. Should they go > > > > into a single directory under /usr/share/salome or into separate module > > > > directories? > > > To my point of view, installing the .m4 files in separate module > > > directories like /usr/share/salome/MODULE_SRC makes more sense with > > > upstream packaging philosophy. I understand the clearness of a single > > > directory like /usr/share/salome/adm_local but I fear conflicts > > > because all modules do not necessarily share the same macro for a same > > > configuration check. > > > > Well, I think it's a problem that they don't use the same macro in some > > cases, like GUI checks... But I'll go ahead and do it this way anyway. > Just for information, the 'geom-use-gui-check.patch' patch is broken > on the 5.1.4 version because the macros 'CHECK_SALOME_GUI' and > 'CHECK_CORBA_IN_GUI' are now defined in the check_GUI.m4 file of > the GEOM module.
Yeah, this bugged me, so I tried to get them all to work with the
version in the GUI module as you suggested.
> From now my solution is to give the path
> '${GUI_ROOT_DIR}/adm_local/unix/config_files' as the first argument
> to aclocal in build_configure (but it could be a problem in case
> a macro really needs to be overloaded locally).
Okay. Aster and Saturne will need to also use
${GUI_ROOT_DIR}/share/salome/${MODULE}_SRC/adm_local/unix/config_files -
is this path set somewhere, so we can include both of these?
> In case you already have a solution for using the same macro, I will
> gladly port it to the 5.1.4 version.
Thanks!
-Adam
--
GPG fingerprint: D54D 1AEE B11C CE9B A02B C5DD 526F 01E8 564E E4B6
Engineering consulting with open source tools
http://www.opennovation.com/
signature.asc
Description: This is a digitally signed message part

