On Sun, Jan 07, 2007 at 05:45:12PM +0100, Petter Reinholdtsen wrote:
> [Vagrant Cascadian]
> > +get_boolean(){
> > + case "$(echo $1 | tr 'A-Z' 'a-z')" in
> > + true|y|yes) return 0 ;;
> > + *) return 1 ;;
> > + esac
> > +}
>
> I'm not sure if this is a good function name for that operation. What
> about boolean_is_true() or something like that.
sure, "booleant_is_true" sounds like a good name to me.
i wasn't happy with the name either, though i was sort of following
ldm's "get_config_bool" function. though if i was really trying to do
that, i should have just called it "get_config_bool".
i don't care too much what to call it, i just want it fixed. :)
live well,
vagrant
--
To UNSUBSCRIBE, email to [EMAIL PROTECTED]
with a subject of "unsubscribe". Trouble? Contact [EMAIL PROTECTED]