Hello,
because I am adopting a setup from Squeeze to Jessie I have to check
also the init scripts. ^^
Whoever would maintain the package in future it would be nice for old
init.d usage that the script behaves a little more debian compliant (?)...
I fixed here already some naming entries but I am not sure if the PIDDIR
and LOGDIR should also be renamed either to package name
gearman-job-server or to the $NAME of the daemon ^^
# diff /etc/init.d/gearman-job-server{,.orig}
23c23
< DAEMON=${exec_prefix}/sbin/$NAME
---
> DAEMON=${exec_prefix}/sbin/gearmand
25c25
< PIDFILE=${PIDDIR}/$NAME.pid
---
> PIDFILE=${PIDDIR}/gearmand.pid
27d26
< LOGFILE=/var/log/gearman-job-server/$NAME.log
38c37
< log_daemon_msg "Starting Gearman Server" "$NAME"
---
> log_daemon_msg "Starting Gearman Server" "gearmand"
50c49
< --log-file=$LOGFILE \
---
> --log-file=/var/log/gearman-job-server/gearman.log \
63c62
< log_daemon_msg "Stopping Gearman Server" "$NAME"
---
> log_daemon_msg "Stopping Gearman Server" "gearmand"
Bests
Reiner