Am 23.01.23 um 08:40 schrieb Pascal Obry:
Hello devs,

As we are not ready to have an automatic reformatting of the code I
have started at least making the function headers a bit more readable.

From:

void dt_gui_presets_show_edit_dialog(const char *name_in, const char 
*module_name, int rowid,
                                      GCallback final_callback, gpointer data, 
gboolean allow_name_change,
                                      gboolean allow_desc_change,
                                      gboolean allow_remove, GtkWindow *parent)

To:

void dt_gui_presets_show_edit_dialog(const char *name_in,
                                      const char *module_name,
                                      const int rowid,
                                      GCallback final_callback,
                                      gpointer data,
                                      const gboolean allow_name_change,
                                      const gboolean allow_desc_change,
                                      const gboolean allow_remove,
                                      GtkWindow *parent)

This is to be done only if the function header does not fit in a single
line of 80 characters.

When I work on a file I'll try to do this change in a separate commit
"Minor reformatting" and I encourage all devs to do the same.

This will make the code a bit more readable and the type/name of the
parameters to stand out a bit more.

Thanks,

While the idea is sound, 80 character wide lines seem so... 1980's. Do
people still need to read and edit darktable source code on 640x480
displays?

___________________________________________________________________________
darktable developer mailing list
to unsubscribe send a mail to darktable-dev+unsubscr...@lists.darktable.org

Reply via email to