CVSROOT:        /cvs/gnome
Module name:    gtk+
Changes by:     carlosg 06/03/08 12:22:14

Modified files:
        .              : ChangeLog 
        gtk            : gtknotebook.c 
        tests          : testnotebookdnd.c 

Log message:
2006-03-08  Carlos Garnacho  <[EMAIL PROTECTED]>

Rename ::tab-added and ::tab-removed signals to ::page-added and
::page-removed for not conflicting with other tab reordering
implementations. Fixes bug #333743 
[http://bugzilla.gnome.org/show_bug.cgi?id=333743].

Also rename ::tab-reordered to ::page-reordered, and emit it in
gtk_notebook_reorder_child () to make it behave consistently with the
other two signals.

* gtk/gtknotebook.c (gtk_notebook_class_init): rename signals.
(gtk_notebook_reorder_tab)
(gtk_notebook_button_release)
(gtk_notebook_remove)
(gtk_notebook_real_insert_page): emit respectively renamed signals
(gtk_notebook_reorder_child): also emit ::page-reordered here

* tests/testnotebookdnd.c: use renamed signals

URL : 
http://cvs.gnome.org/bonsai/cvsquery.cgi?branch=&dir=gtk%2B&who=carlosg&date=explicit&mindate=2006-03-08%2012:21&maxdate=2006-03-08%2012:23

_______________________________________________
cvs-commits-list mailing list
cvs-commits-list@gnome.org
http://mail.gnome.org/mailman/listinfo/cvs-commits-list

Reply via email to