CVSROOT:        /cvs/gnome
Module name:    glib
Changes by:     timj    05/12/05 10:01:27

Modified files:
        docs/reference/glib/tmpl: memory_slices.sgml 
        glib           : glib.symbols glist.c gmain.c gslice.c gslice.h 
                         gslist.c 

Log message:
Mon Dec  5 15:53:20 2005  Tim Janik  <[EMAIL PROTECTED]>

* glib/gslice.c: implement chain walking for arbitrary ->next pointer
offsets in g_slice_free_chain_with_offset() based on a patch by behdad
in bug 323178. moved time consuming logic from g_slice_free() out of
the inner loop, so g_slice_free_chain_with_offset() provides a real
performance benefit over g_slice_free1() now.

* glib/gslice.h: renamed g_slice_free_chain() to
g_slice_free_chain_with_offset(). implemented g_slice_free_chain() as
a type-safe macro as suggested in bug 323178.
simplified the macro implementation of g_slice_free() and implemented
it in a type safe manner for all compliers as suggested by Morten
Welinder <[EMAIL PROTECTED]>.

* glib/gmain.c:
* glib/glist.c:
* glib/gslist.c:
* glib/glib.symbols: s/g_slice_free_chain/g_slice_free_chain_with_offset/

URL : 
http://cvs.gnome.org/bonsai/cvsquery.cgi?branch=&dir=glib&who=timj&date=explicit&mindate=2005-12-05%2010:00&maxdate=2005-12-05%2010:02

_______________________________________________
cvs-commits-list mailing list
cvs-commits-list@gnome.org
http://mail.gnome.org/mailman/listinfo/cvs-commits-list

Reply via email to