marius 2007-01-18 22:01:20 UTC FreeBSD src repository
Modified files: sys/arm/at91 uart_dev_at91usart.c sys/arm/sa11x0 uart_dev_sa1110.c sys/dev/uart uart_cpu.h uart_dev_ns8250.c uart_dev_sab82532.c uart_dev_z8530.c uart_kbd_sun.c Log: - Add a uart_rxready() and corresponding device-specific implementations that can be used to check whether receive data is ready, i.e. whether the subsequent call of uart_poll() should return a char, and unlike uart_poll() doesn't actually receive data. - Remove the device-specific implementations of uart_poll() and implement uart_poll() in terms of uart_getc() and the newly added uart_rxready() in order to minimize code duplication. - In sunkbd(4) take advantage of uart_rxready() and use it to implement the polled mode part of sunkbd_check() so we don't need to buffer a potentially read char in the softc. - Fix some mis-indentation in sunkbd_read_char(). Discussed with: marcel Revision Changes Path 1.11 +5 -7 src/sys/arm/at91/uart_dev_at91usart.c 1.7 +5 -6 src/sys/arm/sa11x0/uart_dev_sa1110.c 1.11 +16 -2 src/sys/dev/uart/uart_cpu.h 1.24 +4 -6 src/sys/dev/uart/uart_dev_ns8250.c 1.15 +4 -6 src/sys/dev/uart/uart_dev_sab82532.c 1.21 +4 -6 src/sys/dev/uart/uart_dev_z8530.c 1.11 +7 -15 src/sys/dev/uart/uart_kbd_sun.c _______________________________________________ cvs-all@freebsd.org mailing list http://lists.freebsd.org/mailman/listinfo/cvs-all To unsubscribe, send any mail to "[EMAIL PROTECTED]"