jasone      2006-04-27 01:03:00 UTC

  FreeBSD src repository

  Modified files:
    lib/libc/stdlib      malloc.c 
  Log:
  Change the semantics of brk_max to dynamically deal with data segment
  bounds. [1]
  
  Modify logic for utilizing the data segment, such that it is possible to
  create huge allocations there.
  
  Shrink the data segment when deallocating a chunk, if it is at the end of
  the data segment.
  
  Rename chunk_size to csize in huge_malloc(), in order to avoid masking a
  static variable of the same name. [1]
  
  Reported by:    Paul Allen <[EMAIL PROTECTED]>
  
  Revision  Changes    Path
  1.125     +83 -71    src/lib/libc/stdlib/malloc.c
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to