On Wed, 27 Aug 2025 08:44:19 GMT, Per Minborg <pminb...@openjdk.org> wrote:
>> Darragh Clarke has updated the pull request incrementally with one >> additional commit since the last revision: >> >> moved repeating code into own method > > src/java.base/macosx/classes/sun/nio/ch/KQueuePoller.java line 76: > >> 74: int i = 0; >> 75: while (i < n) { >> 76: MemorySegment eventMS = KQueue.getEvent(pollArray, i); > > Nit: Can we call these variables `eventSegment`? My reptile part of the brain > first read "event in milliseconds". Yes, I think rename this to kevent to keventSegemnt as it's a kevent struct (which is why the Unsafe usage named it keventAddres). ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/25546#discussion_r2307381472