> This PR is a resubmission after PR #21593 was rolled back, and the unsafe 
> offset overflow issue has been fixed.
> 
> 1) Move getChars methods of StringLatin1 and StringUTF16 to DecimalDigits to 
> reduce duplication.
> 
> 2) HexDigits and OctalDigits also include getCharsLatin1 and getCharsUTF16
> 
> 3) Putting these two methods into DecimalDigits can avoid the need to expose 
> them in JavaLangAccess
> Eliminate duplicate code in BigDecimal
> 
> 4) This PR will improve the performance of Integer/Long.toString and 
> StringBuilder.append(int/long) scenarios. This is because Unsafe.putByte is 
> used to eliminate array bounds checks, and of course this elimination is 
> safe. In previous versions, in Integer/Long.toString and 
> StringBuilder.append(int/long) scenarios, -COMPACT_STRING performed better 
> than +COMPACT_STRING. This is because StringUTF16.getChars uses 
> StringUTF16.putChar, which is similar to Unsafe.putChar, and there is no 
> bounds check.

Shaojin Wen has updated the pull request with a new target base due to a merge 
or a rebase. The incremental webrev excludes the unrelated changes brought in 
by the merge/rebase. The pull request contains 16 additional commits since the 
last revision:

 - Merge remote-tracking branch 'upstream/master' into 
int_get_chars_dedup_202411
 - Merge remote-tracking branch 'upstream/master' into 
int_get_chars_dedup_202411
 - fix unsafe address overflow
 - add benchmark
 - remove comments, from @liach
 - Merge remote-tracking branch 'upstream/master' into 
int_get_chars_dedup_202410
 - fix Helper
 - fix Helper
 - fix Helper
 - unsafe putByte
 - ... and 6 more: https://git.openjdk.org/jdk/compare/750bdc8b...efa6e6b2

-------------

Changes:
  - all: https://git.openjdk.org/jdk/pull/22023/files
  - new: https://git.openjdk.org/jdk/pull/22023/files/ee05a6f5..efa6e6b2

Webrevs:
 - full: https://webrevs.openjdk.org/?repo=jdk&pr=22023&range=02
 - incr: https://webrevs.openjdk.org/?repo=jdk&pr=22023&range=01-02

  Stats: 423 lines in 11 files changed: 405 ins; 6 del; 12 mod
  Patch: https://git.openjdk.org/jdk/pull/22023.diff
  Fetch: git fetch https://git.openjdk.org/jdk.git pull/22023/head:pull/22023

PR: https://git.openjdk.org/jdk/pull/22023

Reply via email to