On Sat, 21 Sep 2024 00:39:47 GMT, Shaojin Wen <s...@openjdk.org> wrote:
>> A very small optimization, split the large method inflate, split the >> infrequently used paths into a method inflateCHAR > > Shaojin Wen has updated the pull request with a new target base due to a > merge or a rebase. The pull request now contains eight commits: > > - Merge remote-tracking branch 'origin/optim_class_file_pool_inflat_202408' > into optim_class_file_pool_inflat_202408 > - Update > src/java.base/share/classes/jdk/internal/classfile/impl/AbstractPoolEntry.java > > Co-authored-by: ExE Boss <3889017+exe-b...@users.noreply.github.com> > - Update > src/java.base/share/classes/jdk/internal/classfile/impl/AbstractPoolEntry.java > > Co-authored-by: ExE Boss <3889017+exe-b...@users.noreply.github.com> > - optimize Utf8EntryImpl inflate > - Merge remote-tracking branch 'upstream/master' into > optim_class_file_pool_inflat_202408 > > # Conflicts: > # > src/java.base/share/classes/jdk/internal/classfile/impl/AbstractPoolEntry.java > - Suggestions from @liach > - fix build error > - optimize Utf8EntryImpl inflate src/java.base/share/classes/jdk/internal/classfile/impl/AbstractPoolEntry.java line 244: > 242: } > 243: > 244: private void inflateCHAR(int singleBytes, int hash) { Can you rename this method to `inflateNonAscii`? ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/20767#discussion_r1773670728