On Wed, 8 May 2024 09:37:58 GMT, Thomas Stuefe <stu...@openjdk.org> wrote:
> This may be food for another RFE, to keep this patch minimal. But a good > solution, to me, would be like this: > > * have the same logic for return codes (1 = error, 0 = success) to ease > understanding > * have clearly named constants (e.g. "LAUNCHER_OK" 0, "LAUNCHER_ERR" = 1) > * have the LEAVE macro take the launcher return code as argument > * have all xxx_LEAVE macros pass in LAUNCHER_ERR to LEAVE > * call the final LEAVE with LAUNCHER_OK > * optionally, define something like "LEAVE_ERR" and "LEAVE_OK" that call > LEAVE with either LAUNCHER_ERR or LAUNCHER_OK, for more concise coding. > > For this patch, I think the return code logic is okay, but I would feel > better if others double-checked. @tstuefe Agreed, I can look into opening another issue to track this after we fix the regression. ------------- PR Comment: https://git.openjdk.org/jdk/pull/18786#issuecomment-2103312450