On Fri, 11 Aug 2023 18:27:47 GMT, Justin Lu <j...@openjdk.org> wrote:

> Please review this PR which is a broad clean up of the DigitList class (used 
> by Format classes in j.text).
> 
> This PR is intended to be a portion of a bigger change (split up to make 
> reviewing easier). 
> 
> The main change simplifying related Rounding Mode logic in `shouldRoundUp()` 
> - (_CEILING/FLOOR_, _HALF_UP/DOWN/EVEN_)
> 
> Other changes include
> - Certain for loops can be replaced with cleaner syntax (E.g. for(;;), empty 
> for loops)
> - Introduce `roundInt(int)` - For use by Integer representations of DigitList
> - Introduce `nonZeroAfterIndex(int)` - To reduce code duplication

This pull request has now been integrated.

Changeset: 96778dd5
Author:    Justin Lu <j...@openjdk.org>
URL:       
https://git.openjdk.org/jdk/commit/96778dd549b596d8884376b19a49aa152efb377b
Stats:     159 lines in 1 file changed: 57 ins; 74 del; 28 mod

8314169: Combine related RoundingMode logic in j.text.DigitList

Reviewed-by: naoto

-------------

PR: https://git.openjdk.org/jdk/pull/15252

Reply via email to