Hi, I'm wondering if we could get rid of the style checking in getters like the following (from HDFS-9733). It's annoying because it's a common Java practice and widely used in the project.
void setBlockLocations(LocatedBlocks blockLocations) {:42: 'blockLocations' hides a field. void setTimeout(int timeout) {:25: 'timeout' hides a field. void setLocatedBlocks(List<LocatedBlock> locatedBlocks) {:46: 'locatedBlocks' hides a field. void setRemaining(long remaining) {:28: 'remaining' hides a field. void setBytesPerCRC(int bytesPerCRC) {:29: 'bytesPerCRC' hides a field. void setCrcType(DataChecksum.Type crcType) {:39: 'crcType' hides a field. void setCrcPerBlock(long crcPerBlock) {:30: 'crcPerBlock' hides a field. void setRefetchBlocks(boolean refetchBlocks) {:35: 'refetchBlocks' hides a field. void setLastRetriedIndex(int lastRetriedIndex) {:34: 'lastRetriedIndex' hides a field. Regards, Kai