Kris20030907 opened a new issue, #9201:
URL: https://github.com/apache/rocketmq/issues/9201

   ### Before Creating the Enhancement Request
   
   - [x] I have confirmed that this should be classified as an enhancement 
rather than a bug/feature.
   
   
   ### Summary
   
   Remove dead code patterns in SelectorParser methods.
   
   ### Motivation
   
   - if (true) return patterns are redundant and misleading
   - Unreachable throw statements clutter code and may cause static analysis 
warnings
   - Cleanup improves code readability and maintainability
   
   ### Describe the Solution You'd Like
   
   - Fix all occurrences in these methods:
   `orExpression()`
   `andExpression()`
   `equalityExpression()`
   `literal()`
   `stringLitteral()`
   `variable()`
   - Direct return instead of if (true) return
   - Remove unreachable throw new Error(...)
   
   ### Describe Alternatives You've Considered
   
   - Keeping redundant code with comments: Rejected as it retains technical 
debt.
   - Repurposing the throw statement: Irrelevant since code is unreachable.
   
   ### Additional Context
   
   ```
   // Pattern to remove in all affected methods:
   {
       if (true) return ...; // <- Remove wrapper
   }
   throw new Error(...);     // <- Dead code
   ```


-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: commits-unsubscr...@rocketmq.apache.org.apache.org

For queries about this service, please contact Infrastructure at:
us...@infra.apache.org

Reply via email to