This is an automated email from the ASF dual-hosted git repository.
cdutz pushed a change to branch refactor/spi3
in repository https://gitbox.apache.org/repos/asf/plc4x.git
from 37ccfc091c chore: Renamed all transports artifactIds to use the plural
form of "transport" to match the directory structure and the naming convention
of other modules.
add 66e80ad8ab feat: Officially added support for ModbusTCP via TLS.
No new revisions were added by this update.
Summary of changes:
plc4j/drivers/modbus/pom.xml | 7 +++++++
.../apache/plc4x/java/modbus/ascii/ModbusAsciiDriver.java | 4 ++--
.../org/apache/plc4x/java/modbus/rtu/ModbusRtuDriver.java | 4 ++--
.../org/apache/plc4x/java/modbus/tcp/ModbusTcpDriver.java | 13 ++++++++++---
...uration.java => ModbusTcpTcpTransportConfiguration.java} | 2 +-
...est.java => ModbusTcpTcpTransportConfigurationTest.java} | 4 ++--
6 files changed, 24 insertions(+), 10 deletions(-)
rename
plc4j/drivers/modbus/src/main/java/org/apache/plc4x/java/modbus/tcp/config/{ModbusTcpTransportConfiguration.java
=> ModbusTcpTcpTransportConfiguration.java} (92%)
rename
plc4j/drivers/modbus/src/test/java/org/apache/plc4x/java/modbus/tcp/config/{ModbusTcpTransportConfigurationTest.java
=> ModbusTcpTcpTransportConfigurationTest.java} (88%)