hudi-bot opened a new issue, #17289:
URL: https://github.com/apache/hudi/issues/17289

   It can be confusing to use "Start" or "Time" without much context as we have 
the checkpoint to resume from and stop at for the incremental queries, and 
instant and completion time in the timeline.  So it would be good to do the 
following renaming and make the names consistent across the code base:
    * "beginCompletionTime": checkpoint to resume from
    * "endCompletionTime": checkpoint to stop at
    * "instantTime"/"commitTime": for instant time or start time of an instant 
on the timeline
    * "completionTime": completion time of an instant
   
   Do not use "startTime", "endTime", etc that can cause confusion.
   
    
   
   ## JIRA info
   
   - Link: https://issues.apache.org/jira/browse/HUDI-8373
   - Type: Sub-task
   - Parent: https://issues.apache.org/jira/browse/HUDI-9107
   - Fix version(s):
     - 1.1.0


-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: [email protected]

For queries about this service, please contact Infrastructure at:
[email protected]

Reply via email to