mchiavac commented on issue #12535:
URL: https://github.com/apache/cloudstack/issues/12535#issuecomment-5933539363

   
   sata is not available in dropdown menu for rootdiskcontroller setting.
   If i force sata string during boot agent,log report:
   
   `2026-10-01 13:28:11,806 WARN  [kvm.resource.LibvirtKvmAgentHook] 
(AgentRequest-Handler-4:[]) (logid:3ba615e1) Shell script 
'/etc/cloudstack/agent/hooks/libvirt-vm-xml-transformer.sh' is not available. 
Transformations will not be applied.
   2026-10-01 13:28:11,806 WARN  [kvm.resource.LibvirtKvmAgentHook] 
(AgentRequest-Handler-4:[]) (logid:3ba615e1) Groovy scripting engine is not 
initialized. Data transformation skipped.
   2026-10-01 13:28:11,809 WARN  [resource.wrapper.LibvirtStartCommandWrapper] 
(AgentRequest-Handler-4:[]) (logid:3ba615e1) LibvirtException 
org.libvirt.LibvirtException: unsupported configuration: IDE controllers are 
unsupported for this QEMU binary or machine type
           at org.libvirt.ErrorHandler.processError(Unknown Source)
           at org.libvirt.ErrorHandler.processError(Unknown Source)
           at org.libvirt.Connect.domainCreateXML(Unknown Source)
           at 
com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.startVM(LibvirtComputingResource.java:2368)
           at 
com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.startVM(LibvirtComputingResource.java:2337)
           at 
com.cloud.hypervisor.kvm.resource.wrapper.LibvirtStartCommandWrapper.execute(LibvirtStartCommandWrapper.java:97)
           at 
com.cloud.hypervisor.kvm.resource.wrapper.LibvirtStartCommandWrapper.execute(LibvirtStartCommandWrapper.java:55)
           at 
com.cloud.hypervisor.kvm.resource.wrapper.LibvirtRequestWrapper.execute(LibvirtRequestWrapper.java:78)
           at 
com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.executeRequest(LibvirtComputingResource.java:2407)
           at com.cloud.agent.Agent.processRequest(Agent.java:813)
           at com.cloud.agent.Agent$AgentRequestHandler.doTask(Agent.java:1295)
           at com.cloud.utils.nio.Task.call(Task.java:83)
           at com.cloud.utils.nio.Task.call(Task.java:29)
           at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
           at 
java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1136)
           at 
java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)
           at java.base/java.lang.Thread.run(Thread.java:840)`
   
   maybe the problem is an hardcoded select in uefi or bios mode like this?
   
   
https://github.com/apache/cloudstack/blob/main/plugins/hypervisors/kvm/src/main/java/com/cloud/hypervisor/kvm/resource/LibvirtVMDef.java#L1107
   


-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: [email protected]

For queries about this service, please contact Infrastructure at:
[email protected]

Reply via email to