[ 
https://issues.apache.org/jira/browse/CASSANDRA-3143?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13175428#comment-13175428
 ] 

Sylvain Lebresne commented on CASSANDRA-3143:
---------------------------------------------

Alright, patch lgtm, +1. Great work Pavel.

Just a few minor details that would be nice to do before committing:
* As mentioned in the previous comments, currently when a row need to be read 
to be put in cache, CFS.cacheRow() decorates the key, which can be avoided just 
by making cacheRow take the DK and create the RowCacheKey internally.
* We should rename setRowCacheCapacity to setRowCacheCapacityMB to match the 
others
* It would be nice to move the cache stats from nodetool cfstats to nodetool 
info, rather than purely removing them
* The saveCaches method still does not respect the cacheKeysToSave options

And of course there is the question of disabling row caching on per-cf basis 
which, as said previously, I think is a must have before we release this 
(because any user that have at least one CF with wide rows (or that just 
happens to be a bad candidate for caching) will need it). So ok to do that post 
commit but let's put it at the top of the todo list then.

                
> Global caches (key/row)
> -----------------------
>
>                 Key: CASSANDRA-3143
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-3143
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Pavel Yaskevich
>            Assignee: Pavel Yaskevich
>            Priority: Minor
>              Labels: Core
>             Fix For: 1.1
>
>         Attachments: 0002-fixes.patch, CASSANDRA-3143-squashed.patch
>
>
> Caches are difficult to configure well as ColumnFamilies are added, similar 
> to how memtables were difficult pre-CASSANDRA-2006.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to