[
https://issues.apache.org/jira/browse/CASSANDRA-16532?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17312276#comment-17312276
]
Andres de la Peña commented on CASSANDRA-16532:
-----------------------------------------------
{quote}I have not changed location of {{disableAutocompaction}} or
{{ALLOW_TOOL_REINIT_FOR_TEST}} as not all tests need it. Let me know wdyt.
{quote}
I think there isn't a big difference between setting
{{ALLOW_TOOL_REINIT_FOR_TEST}} before every test with {{@Begin}}, as it's
currently done, or just once with {{@BeginClass}}. In both cases the property
is set for all the tests, and not only for those tests that need it. I find
using {{@BeginClass}} preferable because it saves some calls and it pairs more
clearly with the {{@AfterClass}} method that resets it. If we wanted to set the
property only for the tests that need it, we could restore the original
{{testToolTestingEnvSetup}} initalization method [this
way|https://github.com/adelapena/cassandra/commit/1db00fed784453a181ba42e09deb19686dbcafd5].
However, I think that setting it at the beginning of the class for all the
tests is easier to read and it doesn't damage the tests that don't need it.
Nevertheless, I don't think this is a very important detail and I'll be happy
with the approach you prefer.
> Fix flaky testSkipScrubCorruptedCounterRowWithTool
> --------------------------------------------------
>
> Key: CASSANDRA-16532
> URL: https://issues.apache.org/jira/browse/CASSANDRA-16532
> Project: Cassandra
> Issue Type: Bug
> Components: Test/unit
> Reporter: Berenguer Blasi
> Assignee: Berenguer Blasi
> Priority: Normal
> Fix For: 4.0-rc
>
> Time Spent: 1h 50m
> Remaining Estimate: 0h
>
> Fix flaky
> [testSkipScrubCorruptedCounterRowWithTool|https://ci-cassandra.apache.org/job/Cassandra-trunk/365/testReport/junit/org.apache.cassandra.db/ScrubTest/testSkipScrubCorruptedCounterRowWithTool_compression/]
--
This message was sent by Atlassian Jira
(v8.3.4#803005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]