[
https://issues.apache.org/jira/browse/CASSANDRA-14523?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16530228#comment-16530228
]
Chris Lohfink commented on CASSANDRA-14523:
-------------------------------------------
If going with the dynamic virtual table i think that can be generic and
creating the MetricTable shouldn't be necessary. Instead maybe a
DynamicVirtualTable or something that does what the current MetricTable
implementation is, then people can just build them inline without creating a
parent class for each.
bq. replacing the ScheduledThreadPoolExecutor...
Agreed. We can just remove all the scheduled timer executors and pull off in
different ticket then to register metrics for tpstats etc as well. We wouldnt
want to put it into DebuggableScheduledThreadPoolExecutor just like we dont put
the metrics in DebuggableThreadPoolExecutor, but instead another layer higher
and then just go through and change current scheduled pools to use that.
bq. I noticed that the patch reformat the name of the pools for exposing them
in the virtual table. We should probably keep the original name as it is a bit
confusing if other tools and logs display a different name.
I think we should use the names in cql naming convention, not camel case. This
is not nodetool and we should look to making things that look and feel right
and intuitive. I think we can safely assume people understand that
MutationStage and mutation_stage are the same thing and it will not confuse
them.
bq. I wonder if we should not use a LocalPartitioner
For the partitioner, {{result.addRow(..., result.newRow(...))}} is awkward
naming... if going with this might need some naming or api changes as it doesnt
really make much sense (clustering instead of newRow or
{{result.newPartition(...).withClustering(...)}}). I think we can push the
changing of the partitioner and change in api to another ticket as it doesnt
have much to do with this.
I can put together an updated PR in a bit
> Thread pool stats virtual table
> -------------------------------
>
> Key: CASSANDRA-14523
> URL: https://issues.apache.org/jira/browse/CASSANDRA-14523
> Project: Cassandra
> Issue Type: New Feature
> Reporter: Chris Lohfink
> Assignee: Chris Lohfink
> Priority: Minor
> Labels: virtual-tables
>
> Expose the thread pools like in status logger/tpstats. Additionally be nice
> to include the scheduled executor pools that are currently unmonitored.
> {code:java}
> cqlsh> select * from system_views.thread_pools;
> thread_pool | active | active_max | completed | pending
> | tasks_blocked | total_blocked
> ----------------------------------+--------+------------+-----------+---------+---------------+---------------
> anti_entropy_stage | 0 | 1 | 0 | 0
> | 0 | 0
> cache_cleanup_executor | 0 | 1 | 0 | 0
> | 0 | 0
> compaction_executor | 0 | 4 | 41 | 0
> | 0 | 0
> counter_mutation_stage | 0 | 32 | 0 | 0
> | 0 | 0
> gossip_stage | 0 | 1 | 0 | 0
> | 0 | 0
> hints_dispatcher | 0 | 2 | 0 | 0
> | 0 | 0
> internal_response_stage | 0 | 8 | 0 | 0
> | 0 | 0
> memtable_flush_writer | 0 | 2 | 5 | 0
> | 0 | 0
> memtable_post_flush | 0 | 1 | 20 | 0
> | 0 | 0
> memtable_reclaim_memory | 0 | 1 | 5 | 0
> | 0 | 0
> migration_stage | 0 | 1 | 0 | 0
> | 0 | 0
> misc_stage | 0 | 1 | 0 | 0
> | 0 | 0
> mutation_stage | 0 | 32 | 247 | 0
> | 0 | 0
> native_transport_requests | 1 | 128 | 28 | 0
> | 0 | 0
> pending_range_calculator | 0 | 1 | 2 | 0
> | 0 | 0
> per_disk_memtable_flush_writer_0 | 0 | 2 | 5 | 0
> | 0 | 0
> read_repair_stage | 0 | 8 | 0 | 0
> | 0 | 0
> read_stage | 0 | 32 | 13 | 0
> | 0 | 0
> repair_task | 0 | 2147483647 | 0 | 0
> | 0 | 0
> request_response_stage | 0 | 8 | 0 | 0
> | 0 | 0
> sampler | 0 | 1 | 0 | 0
> | 0 | 0
> scheduled_fast_tasks | 0 | 2147483647 | 1398 | 1
> | 0 | 0
> scheduled_heartbeat | 0 | 2147483647 | 14 | 1
> | 0 | 0
> scheduled_hotness_tracker | 0 | 2147483647 | 0 | 1
> | 0 | 0
> scheduled_non_periodic_tasks | 0 | 2147483647 | 10 | 0
> | 0 | 0
> scheduled_optional_tasks | 0 | 2147483647 | 5 | 8
> | 0 | 0
> scheduled_summary_builder | 0 | 2147483647 | 0 | 1
> | 0 | 0
> scheduled_tasks | 0 | 2147483647 | 194 | 74
> | 0 | 0
> secondary_index_management | 0 | 1 | 0 | 0
> | 0 | 0
> validation_executor | 0 | 2147483647 | 0 | 0
> | 0 | 0
> view_build_executor | 0 | 1 | 0 | 0
> | 0 | 0
> view_mutation_stage | 0 | 32 | 0 | 0
> | 0 | 0
> {code}
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]