[
https://issues.apache.org/jira/browse/CASSANDRA-14457?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16482413#comment-16482413
]
Aleksey Yeschenko commented on CASSANDRA-14457:
-----------------------------------------------
This looks good, so I only have some bikeshedding to contribute:
1. The table doesn't really represent compaction statistics, so should probably
not name it compaction_stats? I know that the nodetool cmd is named
compactionstats, but that was a bad name too, imo. So perhaps
{{compaction_state}} and {{CompactionStateTable}}, or {{compcation_status}} and
{{CompactionStatusTable}}, or even {{active_compactions}} and
{{ActiveCompactionsTable}}; whichever sounds nicer to your American ear.
2. Should we perhaps use {{int}} as the type for current and total columns,
instead of {{text}}?
3. Maybe don't concat the names of the keyspace and the table? Why not have
them in separate columns, for easier querying?
4. We tend to lowercase enums in table, usually. Can you slap a
{{toLowerCase()}} on {{task_type}} please?
5. I would prefer to have ((keyspace, table), id) or ((keyspace), table, id) as
PRIMARY KEY here, personally.
Upon a quick look, it seems like the only case where we don't have a
keyspace/table attached to a compaction is summary redistribution, which is
performed on all sstables. But it's not really a compaction, so perhaps we
should exclude it from the dataset?
> Add a virtual table with current compactions
> --------------------------------------------
>
> Key: CASSANDRA-14457
> URL: https://issues.apache.org/jira/browse/CASSANDRA-14457
> Project: Cassandra
> Issue Type: New Feature
> Reporter: Chris Lohfink
> Assignee: Chris Lohfink
> Priority: Minor
> Fix For: 4.x
>
>
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]