[ 
https://issues.apache.org/jira/browse/CASSANDRA-2008?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12998635#comment-12998635
 ] 

Jon Hermes commented on CASSANDRA-2008:
---------------------------------------

bq. I am not a fan either of the cli somehow extracting yaml comments
Not what I was suggesting, but Aaron nailed it with the `commands: {name,help}` 
blocks.

Hadn't seen #2007 yet, but that looks very good. Separating node.yaml and 
schema.yaml is good, but separating and throwing away schema.yaml (for a script 
solution) is even better.

I would rename `o.a.c.cli.CliHelp.yaml` to something more generic and move it 
out of cli(conf/config_help.yaml). The cli can read it from there, it's an 
intuitive place to find it for a new user, and it can be mirrored onto the wiki 
and anywhere else it's referenced. 

If there were a way to couple it with or generate it from 
interface/cassandra.thrift:{Ks,Cf}Def, o.a.c.config.Raw{Keyspace,ColumnFamily} 
and o.a.c.config.{KS,CF}MetaData, it would be even better-er. Currently all 
three are kept in sync by force of will which has introduced multiple bugs 
already. (Note: this is not in the scope of this ticket, but would be worth 
keeping in mind.)

> CLI help incorrect in places
> ----------------------------
>
>                 Key: CASSANDRA-2008
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-2008
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Core
>    Affects Versions: 0.7.0
>            Reporter: Aaron Morton
>            Assignee: Aaron Morton
>            Priority: Trivial
>             Fix For: 0.7.3
>
>
> Found some errors in the CLI help, such as these for create column family.
> - memtable_operations: Flush memtables after this many operations
> - memtable_throughput: ... or after this many bytes have been written
> - memtable_flush_after: ... or after this many seconds
> Should be millions of ops, MB's written and minutes not seconds.  Have 
> confirmed thats how the values are used. Will check all the help. 

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to