[ 
https://issues.apache.org/jira/browse/CASSANDRA-12220?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15383765#comment-15383765
 ] 

Sylvain Lebresne commented on CASSANDRA-12220:
----------------------------------------------

That's really just a test problem. The test was creating a cell using 
{{cfMeta.allColumns().iterator().next()}}, which as the name imply, may return 
any column including a primary key one (and turns out whether it returned one 
or not was changing by pre-sizing the collection), while cells are only for 
non-primary key columns.

Since that's only a test problem and a pretty trivial one at that, I took the 
liberty of ninja-committing the fix in commit  
9659a389ca7fe8e96779a73448cb078375f0880a. I also added a assertion in 
{{BufferCell}} so that kind of problem is much more easily detected next time. 
I haven't re-committed the collection pre-sizing patch though, and feel free to 
do so, but it could be nice to do a quick unit test run on it to check 
everything is now fine (I only quickly testing the test that failed here).

> utest RowIndexEntryTest.testC11206AgainstPreviousArray/Shallow failure
> ----------------------------------------------------------------------
>
>                 Key: CASSANDRA-12220
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-12220
>             Project: Cassandra
>          Issue Type: Bug
>            Reporter: Robert Stupp
>
> The unit tests {{RowIndexEntryTest.testC11206AgainstPreviousArray}} and 
> {{RowIndexEntryTest.testC11206AgainstPreviousShallow}} fail after [this 
> single line 
> change|https://github.com/apache/cassandra/commit/70fd80ae43f3902e651c956b6d4d07cbc203d30a#diff-75146ba408a51071a0b19ffdfbb2bb3cL307]
>  as shown in [this 
> build|http://cassci.datastax.com/view/trunk/job/trunk_testall/1044/].
> Reverting that line to {{new HashMap<>()}} fixes the unit test issues - but 
> _does not_ explain why it fails, since initializing a collection with the 
> expected size should not change the overall behaviour. There seems to be 
> something else being wrong.
> /cc [~dbrosius]



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to