[
https://issues.apache.org/jira/browse/CASSANDRA-10202?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15362943#comment-15362943
]
Ariel Weisberg commented on CASSANDRA-10202:
--------------------------------------------
* There is an unused discardSegment in AbstractCommitLogSegmentManager
* Also an unused createSegment
* discardSegment(File) also appears unused.
Otherwise +1.
I was going to complain about WaitQueue readability, but in one case it's
providing a useful metric and in the other it's no better/worse than
synchronized for a simple enough condition.
> simplify CommitLogSegmentManager
> --------------------------------
>
> Key: CASSANDRA-10202
> URL: https://issues.apache.org/jira/browse/CASSANDRA-10202
> Project: Cassandra
> Issue Type: Improvement
> Components: Local Write-Read Paths
> Reporter: Jonathan Ellis
> Assignee: Branimir Lambov
> Priority: Minor
>
> Now that we only keep one active segment around we can simplify this from the
> old recycling design.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)