On 08/08/2012, at 7:46 PM, Uli Kusterer <witness.of.teacht...@gmx.net> wrote:

> Prefix/suffix them with gc_ / _gc ? Alternately, just define them in a .plist 
> and build your table from that, then you don't need to implement named 
> NSColor methods for them at all.
> 


I have a table, that's not a problem.

The SVG standard defines 147 named colours:  
http://www.december.com/html/spec/colorsvg.html

I thought it would be a nice programmer convenience to have NSColor return 
these colours using the same naming convention that it already uses for its 
built-in colours, e.g. +[NSColor lightskyblueColor]; and in the sRGB colour 
space (and note, there's an SVG colour called "linen"). As soon as you go 
adding prefixes of any kind that convenience somewhat evaporates. However, 
since in reality my use for these comes from parsing SVG, it invariably ends up 
using the table lookup anyway and these methods are unused. So for now, simply 
dropping them out of my category altogether is a simple solution.

But yeah, namespaces would be a very nice addition to Objective-C.

--Graham
_______________________________________________

Cocoa-dev mailing list (Cocoa-dev@lists.apple.com)

Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com

Help/Unsubscribe/Update your Subscription:
https://lists.apple.com/mailman/options/cocoa-dev/archive%40mail-archive.com

This email sent to arch...@mail-archive.com

Reply via email to