On Wed, 19 Oct 2011 11:47:22 -0600, John Pannell <[email protected]> said:
>- (CGColorRef)CGColorCopy The CG prefix is not yours to use at the start of a method name. Start with your own prefix. Also, follow the convention that if you're handing back a newly created retained object, the word Create appears early in the title. You know there's a rule that Create means a retained ref is returned, so use that rule in your own name, so that when you come back to this code in a year you'll know what's happening. Also, be descriptive as to what this method does. "Copy" doesn't really cut it. So, maybe call this something like MyCGColorCreateWithCalibratedSpace (or something - I'm not entirely clear on the purpose of the method). m. -- matt neuburg, phd = [email protected], <http://www.apeth.net/matt/> A fool + a tool + an autorelease pool = cool! Programming iOS 4! http://www.apeth.net/matt/default.html#iosbook_______________________________________________ Cocoa-dev mailing list ([email protected]) Please do not post admin requests or moderator comments to the list. Contact the moderators at cocoa-dev-admins(at)lists.apple.com Help/Unsubscribe/Update your Subscription: http://lists.apple.com/mailman/options/cocoa-dev/archive%40mail-archive.com This email sent to [email protected]
