Not enough morning coffee for you,

On Oct 3, 2011, at 7:29 AM, Steve Sisak wrote:

> You do, indeed want:
> 
> self.audioPlayer = [self getSoundFile:"soundfile.wav"];
> 
> or
> 
> [self setAudioPlayer = [self getSoundFile:"soundfile.wav"]];

I think you meant [self setAudioPlayer:[self getSoundFile:"soundfile.wave"]];

I second Steve's suggestion of giving ivars a different name than properties, 
especially when just learning the language. Even after you know the language, 
the distinction will help newbies when they need to work with the code you've 
written.

Aaron_______________________________________________

Cocoa-dev mailing list (Cocoa-dev@lists.apple.com)

Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com

Help/Unsubscribe/Update your Subscription:
http://lists.apple.com/mailman/options/cocoa-dev/archive%40mail-archive.com

This email sent to arch...@mail-archive.com

Reply via email to