On Jul 10, 2008, at 4:25 PM, Matt Burnett wrote:
But most of the time compound statements makes code easier to read. Why do you think apple included valueForKeyPath instead of only valueForKey?
The two are completely unrelated.Key-Value Coding has all kinds of behaviors and heuristics above and beyond simply being a short hand for invoking methods; auto-boxing, simple expressions, accessing ivars without methods, etc...
As for compound statements, feel free to use them if you like them. Just don't whine when you need to set a breakpoint on the nth sub- expression or need to figure out which of the 4 chained method invocations unexpectedly returned nil. ;)
b.bum
smime.p7s
Description: S/MIME cryptographic signature
_______________________________________________ Cocoa-dev mailing list (Cocoa-dev@lists.apple.com) Please do not post admin requests or moderator comments to the list. Contact the moderators at cocoa-dev-admins(at)lists.apple.com Help/Unsubscribe/Update your Subscription: http://lists.apple.com/mailman/options/cocoa-dev/archive%40mail-archive.com This email sent to [EMAIL PROTECTED]