Is it wrong to wish "component" worked like this?

(component (render []
                   (div nil "Hello There!")))

(component (render-state [state]
                         (div nil "Hello There!"))

(component (will-mount [_]
                (js/console.log "mounting!"))L
           (render []
                (div nil "Hello There!")))

...I could see the appeal of the current "component" macro before render-state 
was introduced... I can also see the appeal of using a raw "Reify", but given 
that all the Om interfaces have a single member function, having to write 
"IWillMount (will-mount [] ...))" etc is starting to feel like java boilerplate 

(but maybe such a macro will interfere with other features that I'm overlooking)

-- 
-- 
You received this message because you are subscribed to the Google
Groups "Clojure" group.
To post to this group, send email to clojure@googlegroups.com
Note that posts from new members are moderated - please be patient with your 
first post.
To unsubscribe from this group, send email to
clojure+unsubscr...@googlegroups.com
For more options, visit this group at
http://groups.google.com/group/clojure?hl=en
--- 
You received this message because you are subscribed to the Google Groups 
"Clojure" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to clojure+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to