On Aug 19, 2:16 pm, Sean Devlin <francoisdev...@gmail.com> wrote: > First, I would change the names of functions functions that collide > with core to str-take, str-drop, etc. It's just as much to type, and > it is safe to use these names. Also, it would make it easier for Rich > to promote the library to the standard lib when it's done.
+1 I also think contains? might not be a good name given that it doesn't do the same thing as clojure.core/contains?. Aside from one being constant time and one being linear time, you have: user> (clojure.core/contains? "foobar" "f") false user> (clojure.contrib.str-utils2/contains? "foobar" "f") true I think this is potentially confusing. This also may be another point in favor of making the name str-contains?. An str- prefix would also be consistent with the re-* group of functions that deal with regexes. --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "Clojure" group. To post to this group, send email to clojure@googlegroups.com Note that posts from new members are moderated - please be patient with your first post. To unsubscribe from this group, send email to clojure+unsubscr...@googlegroups.com For more options, visit this group at http://groups.google.com/group/clojure?hl=en -~----------~----~----~----~------~----~------~--~---