Antonio, Your SP couldn't allocate 1768 bytes of memory from the I/O pool for a spanning tree update because the I/O pool's free 148112 bytes was so fragmented it couldn't find a contiguous block of 1768 bytes.
This does not necessarily point to a bug. Eliminating spanning tree storms and a once-in-while proactive reboot will go a long way to coalesce fragmented memory blocks. eninja www.multiven.com - simple, efficient & affordable maintenance for all networks™ On Nov 5, 2010, at 9:25 AM, "Antonio Soares" <[email protected]> wrote: > Hello group, > > I'm troubleshooting a STP loop that seemed to be triggered by these errors: > > ++++++++++++++++++++++++++++++++ > %PM_SCP-SP-3-LCP_FW_ABLC: Late collision message from module 1, port:029 > %IPC-SP-5-WATERMARK: 15612 messages pending in xmt for the port > CHKPT:STANDBY SP(2080000.B) seat 2080000 > %IPC-SP-5-WATERMARK: 20068 messages pending in xmt for the port > CHKPT:STANDBY SP(2080000.B) seat 2080000 > %IPC-SP-5-WATERMARK: 22904 messages pending in xmt for the port > CHKPT:STANDBY SP(2080000.B) seat 2080000 > %PM_SCP-SP-3-LCP_FW_ABLC: Late collision message from module 2, port:039 > %IPC-SP-5-WATERMARK: 25710 messages pending in xmt for the port > CHKPT:STANDBY SP(2080000.B) seat 2080000 > %IPC-SP-5-WATERMARK: 28510 messages pending in xmt for the port > CHKPT:STANDBY SP(2080000.B) seat 2080000 > %PM_SCP-SP-3-LCP_FW_ABLC: Late collision message from module 2, port:039 > %IPC-SP-5-WATERMARK: 30344 messages pending in xmt for the port > CHKPT:STANDBY SP(2080000.B) seat 2080000 > > %SYS-SP-2-MALLOCFAIL: Memory allocation of 1768 bytes failed from > 0x4020DCC8, alignment 32 > Pool: I/O Free: 148112 Cause: Memory fragmentation > Alternate Pool: None Free: 0 Cause: No Alternate pool > > -Process= "Spanning Tree", ipl= 2, pid= 126 > -Traceback= 40280990 402826F8 4020DCD0 4020E064 402108DC 4020D0B8 40AAB1BC > 40AAB64C 404A3970 404C4F64 404C51A8 404C5460 404AAA58 404AAE40 40A9EE00 > 40A9D71C > ++++++++++++++++++++++++++++++++ > > These were seen on one of core's 6500. The 6500s are running 12.2.18SXF7. > > Fortunately the problem went away by itself. The last thing we want is a STP > loop in a network with several 6500s and 4500s, right ? :) > > Anyone has seen something like this ? I'm now hitting Bug Toolkit to see if > this was reported before. > > > Thanks. > > Regards, > > Antonio Soares, CCIE #18473 (R&S/SP) > [email protected] > > > _______________________________________________ > cisco-nsp mailing list [email protected] > https://puck.nether.net/mailman/listinfo/cisco-nsp > archive at http://puck.nether.net/pipermail/cisco-nsp/ _______________________________________________ cisco-nsp mailing list [email protected] https://puck.nether.net/mailman/listinfo/cisco-nsp archive at http://puck.nether.net/pipermail/cisco-nsp/
