alexfh added a comment. A couple of comments from a cursory look. I'll try to look closer later this week.
================ Comment at: clang-tidy/ClangTidyDiagnosticConsumer.h:173 + /// \brief Control storage of profile date. + void setStoreProfile(StringRef ProfilePrefix); + llvm::Optional<ClangTidyProfiling::StorageParams> getStoreProfile() const; ---------------- The name is misleading. I'd suggest using a name that unambiguously states that we're setting a prefix for profiling output files. Some ideas: setProfilePathPrefix, setStoredProfilePathPrefix, setProfileStorePathPrefix, setProfileResultsPathPrefix. ================ Comment at: clang-tidy/ClangTidyDiagnosticConsumer.h:174 + void setStoreProfile(StringRef ProfilePrefix); + llvm::Optional<ClangTidyProfiling::StorageParams> getStoreProfile() const; + ---------------- getProfileStorageParams? Repository: rCTE Clang Tools Extra https://reviews.llvm.org/D46602 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits