MaskRay added inline comments.
================ Comment at: clangd/FuzzyMatch.h:61 bool allowMatch(int P, int W) const; - int skipPenalty(int W, Action Last) const; - int matchBonus(int P, int W, Action Last) const; + int missScore(int W, Action Last) const; + int matchScore(int P, int W, Action Last) const; ---------------- sammccall wrote: > FWIW, I don't think this is an improvement - I think the clarity of purpose > in names is more useful than having consistent signs in this case. Keep `matchBonus` but rename `skipPenalty` to `missPenalty` ? Repository: rCTE Clang Tools Extra https://reviews.llvm.org/D44720 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits