timshen added inline comments.
================ Comment at: clang-tidy/readability/SIMDIntrinsicsCheck.cpp:24 + if (Name.startswith("vec_")) + Name = Name.substr(4); + else ---------------- Can you either find or create a wrapper for this? bool StripPrefix(StringRef Prefix, StringRef& S) { if (S.startwith(Prefix)) { S = S.substr(Prefix.size()); return true; } return false; } Which is a huge readability boost and DRY. Repository: rCTE Clang Tools Extra https://reviews.llvm.org/D42983 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits