alexfh added inline comments.
================ Comment at: clang-tidy/modernize/ModernizeTidyModule.cpp:50 + CheckFactories.registerCheck<AvoidFunctionalCheck>( + "modernize-avoid-functional"); CheckFactories.registerCheck<DeprecatedHeadersCheck>( ---------------- aaron.ballman wrote: > I'm not keen on this name -- it suggests the user should avoid functional, > which is certainly not the advice we want to give them. Also, it makes no > mention of deprecations, which is what the check is all about. > > How about: `modernize-functional-deprecations` and we can use > `modernize-deprecations` as the eventual catch-all umbrella, > `modernize-<header name>-deprecations` for other headers, and > `modernize-<header name>-deprecations-<api>` if we want to add API-level > granularity? I'd suggest to put "deprecations" first: modernize-deprecations-functional. Or maybe modernize-deprecated-functional? https://reviews.llvm.org/D42730 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits