paulwalker-arm marked 3 inline comments as done. paulwalker-arm added inline comments.
================ Comment at: lib/CodeGen/CGExprComplex.cpp:773 // supported imaginary types in addition to complex types. - if (RHSi) { + if (RHSi && !FMF.isFast()) { BinOpInfo LibCallOp = Op; ---------------- hfinkel wrote: > fhahn wrote: > > Would the following structure be slightly easier to read? > > > > if (RHSi) { > > if (FMF.isFast()) { simplify } else {libcall} > > } > I'd use CGF.getLangOpts().FastMath (instead of interrogating the implicit > state stored in the IR builder). Probably subjective but in this instance I preferred the look with fewer nested conditionals. https://reviews.llvm.org/D40299 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits