eugenis added inline comments.
================ Comment at: clang/include/clang/Basic/Sanitizers.def:47 +SANITIZER("hwaddress", HWAddress) + ---------------- alekseyshl wrote: > Why didn't we follow KASan style and name it "hw-address"? A matter of taste, I guess. I don't want the attribute to be sanitize_hw_address, too many underscores. Also, kernel is a word and hw is just to letters. ================ Comment at: clang/lib/Driver/SanitizerArgs.cpp:383 + std::make_pair(Efficiency, Address | HWAddress | Leak | Thread | Memory | + KernelAddress), + std::make_pair(Scudo, Address | HWAddress | Leak | Thread | Memory | ---------------- alekseyshl wrote: > Nit: 4 less spaces here and for the next pair. https://bugs.llvm.org/show_bug.cgi?id=35563 https://reviews.llvm.org/D40936 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits