vlad.tsyrklevich added inline comments.
================ Comment at: lib/AST/Decl.cpp:3953 ReasonToReject = 5; // is standard layout. - else if (Blacklist.isBlacklistedLocation(getLocation(), "field-padding")) + else if (Blacklist.isBlacklistedLocation(ASanMask, getLocation(), + "field-padding")) ---------------- eugenis wrote: > Looks like this is another case of missing "& LangOpts.Sanitize.Mask" ? Indeed. ================ Comment at: lib/Basic/XRayLists.cpp:29 // whether it's treated as a "never" instrument function. - if (AlwaysInstrument->inSection("fun", FunctionName, "arg1")) + if (AlwaysInstrument->inSection("xray_always_instrument", "fun", FunctionName, + "arg1")) ---------------- eugenis wrote: > It feels redundant to have AlwaysInstrument and NeverInstrument lists, and > then the same distinction in section names. Maybe sections could be named > "xray" in both cases? Or, better, the lists could be merged into a single > list with always and never sections? There is also an issue of backward > compatibility. Anyway, that's for xray devs to decide. @dberris I chose this approach for backwards compatibility, but I'd defer to what @dberris thinks is best. https://reviews.llvm.org/D37925 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits